package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\d]*([\d]*)[\d]`)
var str = `0066 435sxxzx 23454 2 3 45 06 0066 11.3243
sds435 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}