const regex = /[\d]*([\d]*)[\d]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\d]*([\\d]*)[\\d]', 'g')
const str = `0066 435sxxzx 23454 2 3 45 06 0066 11.3243
sds435 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}