$re = '/[\d]*([\d]*)[\d]/';
$str = '0066 435sxxzx 23454 2 3 45 06 0066 11.3243
sds435 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);