use strict;
my $str = '"return this question ";';
my $regex = qr/^ *return[ \t]+[^\n;]*;/mp;
my $subst = '{\\g<0>}';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";