// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^ *return[ \t]+[^\n;]*;").unwrap();
let string = "\"return this question \";";
let substitution = "{\\g<0>}";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}