package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*_?)phone(_.*)?$`)
var str = `phone
office_phone
home_phone
phone_number`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}