$re = '/^(.*_?)phone(_.*)?$/m';
$str = 'phone
office_phone
home_phone
phone_number';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);