$re = '/(?:(da|en-gb|en|\*))(?!.*\1(?!-))(?:;q=(?:1|0(\.\d+)?))?(?:,(da|en-gb|en|\*)(?!.*\3(?!-))(?:;q=(?:1|0(?:\.\d+)?))?)*/';
$str = 'enenen-gben
enenenen-gb
Accept-Language: da, en-gb;q=0.8, en;q=0.7
en;q=0,da;q=0.4,*;q=0.4,da;q=0.4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);