import re
regex = re.compile(r"(?:(da|en-gb|en|\*))(?!.*\1(?!-))(?:;q=(?:1|0(\.\d+)?))?(?:,(da|en-gb|en|\*)(?!.*\3(?!-))(?:;q=(?:1|0(?:\.\d+)?))?)*")
test_str = ("enenen-gben\n\n"
"enenenen-gb\n\n"
"Accept-Language: da, en-gb;q=0.8, en;q=0.7\n"
"en;q=0,da;q=0.4,*;q=0.4,da;q=0.4")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")