import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "var .*?Scope.*?=[\\s\\S]*?\\{([\\s\\S]*?)\\};[\\s\\S]*?var .*?Directive.*?=[\\s\\S]*?\\{([\\s\\S]*?)\\};[\\s\\S]*?encModule.directive\\(['\"](.*?)['\"][\\s\\S]*";
final String string = "//------------------------------------------------------------------\n"
+ "// PrivacyAgreementDialogDirective.js\n"
+ "// Copyright 2013 AppliedMinds, Inc.\n"
+ "//------------------------------------------------------------------\n\n"
+ "\"use strict\";\n\n"
+ "//------------------------------------------------------------------\n"
+ "// Map of attributes to be copied into the scope.\n"
+ "var privacyAgreementDialogScope =\n"
+ "{\n"
+ "};\n\n"
+ "//------------------------------------------------------------------\n"
+ "// Configuration of the privacyAgreementDialog directive.\n"
+ "var privacyAgreementDialogDirective =\n"
+ "{\n"
+ " 'restrict' : 'E',\n"
+ " 'transclude' : true,\n"
+ " 'scope' : privacyAgreementDialogScope,\n"
+ " 'controller' : 'PrivacyAgreementDialogCtrl',\n"
+ " 'templateUrl' : 'encirca/common/privacyAgreementDialog/PrivacyAgreementDialog.html',\n"
+ " 'replace' : true\n"
+ "};\n\n"
+ "//------------------------------------------------------------------\n"
+ "// Create the directive.\n"
+ "encModule.directive('privacyAgreementDialog',\n"
+ " enc.func.returns(privacyAgreementDialogDirective));\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}