// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"var .*?Scope.*?=[\s\S]*?{([\s\S]*?)};[\s\S]*?var .*?Directive.*?=[\s\S]*?{([\s\S]*?)};[\s\S]*?encModule.directive\(['"](.*?)['"][\s\S]*"#).unwrap();
let string = "//------------------------------------------------------------------
// PrivacyAgreementDialogDirective.js
// Copyright 2013 AppliedMinds, Inc.
//------------------------------------------------------------------
\"use strict\";
//------------------------------------------------------------------
// Map of attributes to be copied into the scope.
var privacyAgreementDialogScope =
{
};
//------------------------------------------------------------------
// Configuration of the privacyAgreementDialog directive.
var privacyAgreementDialogDirective =
{
'restrict' : 'E',
'transclude' : true,
'scope' : privacyAgreementDialogScope,
'controller' : 'PrivacyAgreementDialogCtrl',
'templateUrl' : 'encirca/common/privacyAgreementDialog/PrivacyAgreementDialog.html',
'replace' : true
};
//------------------------------------------------------------------
// Create the directive.
encModule.directive('privacyAgreementDialog',
enc.func.returns(privacyAgreementDialogDirective));
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}