package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)f+\s*u+\s*c+\s*k+`)
var str = `.djrFUCK.sjnw F U C K fUcK
ffuuuck fuuuucccck Fuuck F uck`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}