$re = '/f+\s*u+\s*c+\s*k+/mix';
$str = '.djrFUCK.sjnw F U C K fUcK
ffuuuck fuuuucccck Fuuck F uck';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);