re = /f+\s*u+\s*c+\s*k+/mix
str = '.djrFUCK.sjnw F U C K fUcK
ffuuuck fuuuucccck Fuuck F uck'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end