import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!\\S{13})(?:COT|MED)[ABCD]?-?\\d{1,4}(?:[JK]+\\d*|(?: [A-Z]+)?)";
final String string = "MED-123\n"
+ "COTA-1224\n"
+ "MED4\n"
+ "COTB-892K777\n"
+ "MED-33 DDD\n"
+ "MED-234J5678\n"
+ "COT-1111J11111111111111";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}