const regex = /(?!\S{13})(?:COT|MED)[ABCD]?-?\d{1,4}(?:[JK]+\d*|(?: [A-Z]+)?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!\\S{13})(?:COT|MED)[ABCD]?-?\\d{1,4}(?:[JK]+\\d*|(?: [A-Z]+)?)', 'g')
const str = `MED-123
COTA-1224
MED4
COTB-892K777
MED-33 DDD
MED-234J5678
COT-1111J11111111111111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}