re = /(?!\S{13})(?:COT|MED)[ABCD]?-?\d{1,4}(?:[JK]+\d*|(?: [A-Z]+)?)/
str = 'MED-123
COTA-1224
MED4
COTB-892K777
MED-33 DDD
MED-234J5678
COT-1111J11111111111111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end