using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"0205052I0(?!BB).*";
string input = @"0205052I0AAAAAA
0205052I0ACAAAA
0205052I0BCABAA
0205052I0BBABAA";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}