$re = '/0205052I0(?!BB).*/';
$str = '0205052I0AAAAAA
0205052I0ACAAAA
0205052I0BCABAA
0205052I0BBABAA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);