re = /0205052I0(?!BB).*/
str = '0205052I0AAAAAA
0205052I0ACAAAA
0205052I0BCABAA
0205052I0BBABAA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end