using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"locador[a]?:(.*)";
string input = @"LOCADOR: Jose Reinaldo Lellis de Andrade
LOCADORA: Isabel Cristina de Rezende Leme Ferreira Andrade";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}