package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)locador[a]?:(.*)`)
var str = `LOCADOR: Jose Reinaldo Lellis de Andrade
LOCADORA: Isabel Cristina de Rezende Leme Ferreira Andrade`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}