re = /locador[a]?:(.*)/i
str = 'LOCADOR: Jose Reinaldo Lellis de Andrade
LOCADORA: Isabel Cristina de Rezende Leme Ferreira Andrade'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end