using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^612\s?[1-5]0\s?0(?:[0-5]\d|6[0-4])\s?0000\s?(?:[0-5]\d|6[0-4])\s?(?:[0-5]\d|6[0-4])\s?(?:[0-9][1-9][2-9][2-9])$";
string input = @"61230005000055010121
61230005000055640122
61230005000055630120
61230005000055750123
612 30 005 0000 55 01 0121
612 30 005 0000 55 64 0122
612 30 005 0000 55 95 0123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}