use strict;
my $str = '61230005000055010121
61230005000055640122
61230005000055630120
61230005000055750123
612 30 005 0000 55 01 0121
612 30 005 0000 55 64 0122
612 30 005 0000 55 95 0123';
my $regex = qr/^612\s?[1-5]0\s?0(?:[0-5]\d|6[0-4])\s?0000\s?(?:[0-5]\d|6[0-4])\s?(?:[0-5]\d|6[0-4])\s?(?:[0-9][1-9][2-9][2-9])$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}