import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^612\\s?[1-5]0\\s?0(?:[0-5]\\d|6[0-4])\\s?0000\\s?(?:[0-5]\\d|6[0-4])\\s?(?:[0-5]\\d|6[0-4])\\s?(?:[0-9][1-9][2-9][2-9])$";
final String string = "61230005000055010121\n\n"
+ "61230005000055640122\n\n"
+ "61230005000055630120\n\n"
+ "61230005000055750123\n\n"
+ "612 30 005 0000 55 01 0121\n\n\n"
+ "612 30 005 0000 55 64 0122\n\n\n"
+ "612 30 005 0000 55 95 0123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}