import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?:\\D*\\d\\D*){8,14}$)[- \\d()+]*";
final String string = "12345678901234\n"
+ "123 456789 0 1 2 3 4\n"
+ "+1 2345678901234\n"
+ "(12) 3 4 56 7 8 9 01234\n"
+ "1-2-3-4-5-6-7 8 9 0 123 4\n"
+ "1-2-3-4-5-6-7 8 9 0 123 47";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}