const regex = /^(?=(?:\D*\d\D*){8,14}$)[- \d()+]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(?:\\D*\\d\\D*){8,14}$)[- \\d()+]*', 'gm')
const str = `12345678901234
123 456789 0 1 2 3 4
+1 2345678901234
(12) 3 4 56 7 8 9 01234
1-2-3-4-5-6-7 8 9 0 123 4
1-2-3-4-5-6-7 8 9 0 123 47`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}