re = /^(?=(?:\D*\d\D*){8,14}$)[- \d()+]*/m
str = '12345678901234
123 456789 0 1 2 3 4
+1 2345678901234
(12) 3 4 56 7 8 9 01234
1-2-3-4-5-6-7 8 9 0 123 4
1-2-3-4-5-6-7 8 9 0 123 47'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end