#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d:[0-5]\d$"
Local $sString = "0:00" & @CRLF & _
"1:34" & @CRLF & _
"156" & @CRLF & _
"3:67" & @CRLF & _
"45:55" & @CRLF & _
"56" & @CRLF & _
"4:344"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")