package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d:[0-5]\d$`)
var str = `0:00
1:34
156
3:67
45:55
56
4:344`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}