$re = '/^\d:[0-5]\d$/m';
$str = '0:00
1:34
156
3:67
45:55
56
4:344';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);