import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https:\\/\\/www.google.([^\\/]*)\\/(search|webhp)\\?(?!.*(tbm\\=isch|tbm\\=news|param1\\=432)).*$";
final String string = "https://www.google.co.in/search?q=fdsfsf&oq=fdsfsf&sourceid=chrome&ie=UTF-8\n"
+ "https://www.google.co.in/search?q=fdsfsf&oq=fdsfsf&sourceid=chrome&ie=UTF-8&tbm=isch";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}