re = /^https:\/\/www.google.([^\/]*)\/(search|webhp)\?(?!.*(tbm\=isch|tbm\=news|param1\=432)).*$/m
str = 'https://www.google.co.in/search?q=fdsfsf&oq=fdsfsf&sourceid=chrome&ie=UTF-8
https://www.google.co.in/search?q=fdsfsf&oq=fdsfsf&sourceid=chrome&ie=UTF-8&tbm=isch'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end