use strict;
my $str = 'https://www.google.co.in/search?q=fdsfsf&oq=fdsfsf&sourceid=chrome&ie=UTF-8
https://www.google.co.in/search?q=fdsfsf&oq=fdsfsf&sourceid=chrome&ie=UTF-8&tbm=isch';
my $regex = qr/^https:\/\/www.google.([^\/]*)\/(search|webhp)\?(?!.*(tbm\=isch|tbm\=news|param1\=432)).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}