using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<A.+?class\s*?=(['\""])?(?:whtbigheader)\1[^>]*>(.*?)<\/A>";
string input = @"<A HREF='/articles/0,7340,L-4664450,00.html' CLASS='whtbigheader' style='color:#FFFFFF;' HM=1>need to get this value</A>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}