const regex = /<A.+?class\s*?=(['\"])?(?:whtbigheader)\1[^>]*>(.*?)<\/A>/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<A.+?class\\s*?=([\'\\"])?(?:whtbigheader)\\1[^>]*>(.*?)<\\\/A>', 'gmi')
const str = `<A HREF='/articles/0,7340,L-4664450,00.html' CLASS='whtbigheader' style='color:#FFFFFF;' HM=1>need to get this value</A>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}