$re = '/<A.+?class\s*?=([\'\"])?(?:whtbigheader)\1[^>]*>(.*?)<\/A>/mi';
$str = '<A HREF=\'/articles/0,7340,L-4664450,00.html\' CLASS=\'whtbigheader\' style=\'color:#FFFFFF;\' HM=1>need to get this value</A>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);