import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:Apartment|Apt|Block|Department|Lot|Number|Villa)\\s*[0-9]+(*SKIP)(?!)|\\d+";
final String string = "23 St John Apt 92 rer 4, Wellington Country Block 5 No value test 4545 tt 232";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}