re = /\b(?:Apartment|Apt|Block|Department|Lot|Number|Villa)\s*[0-9]+(*SKIP)(?!)|\d+/
str = '23 St John Apt 92 rer 4, Wellington Country Block 5 No value test 4545 tt 232'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end