const regex = /\b(?:Apartment|Apt|Block|Department|Lot|Number|Villa)\s*[0-9]+(*SKIP)(?!)|\d+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:Apartment|Apt|Block|Department|Lot|Number|Villa)\\s*[0-9]+(*SKIP)(?!)|\\d+', 'g')
const str = `23 St John Apt 92 rer 4, Wellington Country Block 5 No value test 4545 tt 232`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}