const regex = /(<p[^<>]*>[\w\s]{5})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<p[^<>]*>[\\w\\s]{5})', '')
const str = `<html><p style="border:1px solid #000">this is my text</p></html>`;
const subst = `\1<br>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);