package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(-?[0-9]+(?:[,.][0-9]+)?)`)
var str = `123
-123.21
0.1
123
H3.07LLo my nam3 is bob12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}