re = /(-?[0-9]+(?:[,.][0-9]+)?)/m
str = '123
-123.21
0.1
123
H3.07LLo my nam3 is bob12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end