re = /^.*\d{2}:\d{2}\s+/m
str = '-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml
-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml
-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml
-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml
-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml
-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result