import Foundation
let pattern = #"^.*\d{2}:\d{2}\s+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml
-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml
-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml
-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml
-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml
-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)