import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?!ISSN).)*(?![^()]*\\))\\s(\\d+-\\d+)$";
final String string = "Journal Name, Vol. 20, No. 2; p. 15\n"
+ "Journal Name, Vol. 20, No. 2: Human Name (1990-2010); p. 15\n"
+ "Journal Name, Vol. 20, No. 2: Human Name (1990-2010); pp. 15-20\n"
+ "Journal Name, Vol. 20, No. 2: Human Name (1990-2010); pp. 15-\n"
+ "Journal Name, Vol. 20, No. 2; 20-25\n"
+ "Journal Name, Vol. 20, No. 2; ISSN: 1234-1234 (Print); 20-25\n"
+ "Journal Name, Vol. 20, No. 2; 20-25; ISSN: 1234-1234 (Print)\n"
+ "Journal Name, Vol. 20, No. 2; ISSN: 1234-1234 (Print); ISSN: 1234-1234 (Online); 20-25\n"
+ "Journal Name, Vol. 20, No. 2; ISSN 1234-1234 (Print); ISSN 1234-1234 (Online); 20-25";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}