import Foundation
let pattern = #"^((?!ISSN).)*(?![^()]*\))\s(\d+-\d+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Journal Name, Vol. 20, No. 2; p. 15
Journal Name, Vol. 20, No. 2: Human Name (1990-2010); p. 15
Journal Name, Vol. 20, No. 2: Human Name (1990-2010); pp. 15-20
Journal Name, Vol. 20, No. 2: Human Name (1990-2010); pp. 15-
Journal Name, Vol. 20, No. 2; 20-25
Journal Name, Vol. 20, No. 2; ISSN: 1234-1234 (Print); 20-25
Journal Name, Vol. 20, No. 2; 20-25; ISSN: 1234-1234 (Print)
Journal Name, Vol. 20, No. 2; ISSN: 1234-1234 (Print); ISSN: 1234-1234 (Online); 20-25
Journal Name, Vol. 20, No. 2; ISSN 1234-1234 (Print); ISSN 1234-1234 (Online); 20-25
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)