# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?!ISSN).)*(?![^()]*\))\s(\d+-\d+)$"
test_str = ("Journal Name, Vol. 20, No. 2; p. 15\n"
"Journal Name, Vol. 20, No. 2: Human Name (1990-2010); p. 15\n"
"Journal Name, Vol. 20, No. 2: Human Name (1990-2010); pp. 15-20\n"
"Journal Name, Vol. 20, No. 2: Human Name (1990-2010); pp. 15-\n"
"Journal Name, Vol. 20, No. 2; 20-25\n"
"Journal Name, Vol. 20, No. 2; ISSN: 1234-1234 (Print); 20-25\n"
"Journal Name, Vol. 20, No. 2; 20-25; ISSN: 1234-1234 (Print)\n"
"Journal Name, Vol. 20, No. 2; ISSN: 1234-1234 (Print); ISSN: 1234-1234 (Online); 20-25\n"
"Journal Name, Vol. 20, No. 2; ISSN 1234-1234 (Print); ISSN 1234-1234 (Online); 20-25")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.