import re
regex = re.compile(r"Subject :\s*([\s\S]*?)(?=\*+end of input\*+)")
test_str = ("Subject :\n\n"
"So for example, one field can span any number of lines and then there will be a message similar to\n"
"****end of input****\n\n"
"It will match anything after the colon until it hits a new line character. This works for almost all of the fields I need to scrape. One however, is a bit more trouble. One of them, the last one I need to scrape (not shown above) will span multiple lines. There's no way to predict how long it will be, but instead I have another predefined piece of text I can use to determine where to stop capturing.")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")